Login Issues
Incident Report for Labelbox
Resolved
This incident has been resolved.
Posted Oct 06, 2022 - 15:21 UTC
Investigating
We’re experiencing a service outage impacting users’ ability to log in. Our team is currently working to restore the service. We apologize for any inconvenience.
Posted Oct 06, 2022 - 14:59 UTC
This incident affected: Annotate and Platform (common services).