Database connection issue
Incident Report for Labelbox
Postmortem

There were network and connection issues with our database and our API, leading to a delay in response time and failed requests to retrieve data. We scaled our services and spun up additional API instances to handle new requests, while shutting down existing instances that had connection issues. We’ve added in additional error handling and logging around any connection issues, and are working on a service that will be responsible for the intermediary between storage and services.

Posted Feb 19, 2020 - 04:08 UTC

Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 08:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2020 - 08:02 UTC
Investigating
We are currently investigating this issue.
Posted Feb 17, 2020 - 07:54 UTC
This incident affected: Platform (common services).