Load balancer down
Incident Report for Labelbox
Postmortem

There was a misconfiguration on our load balancer where it automatically updated to the next minor version at 7:00pm PDT. In doing so, new required configuration options were not set, leading the load balancer to not restart successfully. We received a pager alert that the application was down, identified that it was the load balancer, and set about determining the issue. We then downgraded to our previous version, and after doing so, it started successfully and the application came back fully online at 7:57pm PDT. Action items resulting from this outage are:

  • Modifying the load balancer configuration to be pegged to a specific version and not auto-upgrade.
  • Establishing a process to manually upgrade our load balancer.
Posted Sep 18, 2019 - 22:37 UTC

Resolved
This incident has been resolved.
Posted Sep 12, 2019 - 03:00 UTC
Investigating
We are currently investigating the issue
Posted Sep 12, 2019 - 02:17 UTC
This incident affected: Platform (common services).