Labeling queues in the annotation platform are degraded.

Incident Report for Labelbox

Resolved

We have confirmed the fix was successful and are moving the status to resolved.
Posted Aug 03, 2026 - 19:52 UTC

Monitoring

A fix has been successfully deployed to production. We are closely monitoring system performance and metrics to ensure complete stability. Normal operations have resumed.
Posted Aug 03, 2026 - 19:17 UTC

Identified

There is an ongoing orchestration incident that has resulted in labeling queues in some projects to be degraded. The issue has been identified and a fix will be rolled out shortly after further testing.
Posted Aug 03, 2026 - 18:32 UTC
This incident affected: Annotate.