Saving & submitting labels performance degradation

Incident Report for Labelbox

Resolved

This incident has been resolved.
Posted Jun 26, 2024 - 22:50 UTC

Investigating

We are currently investigating this issue.
Posted Jun 26, 2024 - 20:34 UTC
This incident affected: Annotate.