Labelbox Queue Issues
Incident Report for Labelbox
Resolved
This incident has been resolved.
Posted Oct 29, 2024 - 23:06 UTC
Identified
We are currently experiencing issues with the Labelbox queue system impacting task assignment and processing times.
Posted Oct 29, 2024 - 22:52 UTC
This incident affected: Annotate.