System Slowness
Incident Report for Labelbox
Resolved
The incident has been resolved.
Posted Feb 23, 2021 - 06:23 UTC
Investigating
Some customers may be experiencing increased delay retrieving assets from their labeling queues. We're urgently working to restore normal service.
Posted Feb 23, 2021 - 06:14 UTC
This incident affected: Annotate and Platform (common services).