Project Loading Issue
Incident Report for Labelbox
Resolved
This incident is resolved.
Posted Mar 25, 2024 - 19:25 UTC
Monitoring
Projects are now accessible. We are monitoring any further latency.
Posted Mar 25, 2024 - 19:10 UTC
Identified
The issue has been identified and we are looking into a fix.
Posted Mar 25, 2024 - 18:46 UTC
This incident affected: Annotate.