Labeling workflow performance affected

Incident Report for Labelbox

Resolved

Incident is resolved.
Posted Jul 31, 2025 - 07:54 UTC

Monitoring

We have identified the root cause, which is being mitigated. Monitoring.
Posted Jul 31, 2025 - 05:09 UTC

Update

We are continuing to investigate this issue.
Posted Jul 31, 2025 - 05:07 UTC

Investigating

We are investigating general slowness and lag in various parts of the labeling workflow.
Posted Jul 31, 2025 - 04:47 UTC
This incident affected: Annotate.