Latency on Labelbox Annotate Editors
Incident Report for Labelbox
Resolved
This incident has been resolved.
Posted Aug 29, 2023 - 14:49 UTC
Update
We are continuing to investigate this issue.
Posted Aug 29, 2023 - 14:48 UTC
Investigating
We are currently investigating this issue.
Posted Aug 29, 2023 - 14:27 UTC
This incident affected: Annotate.