Labelbox platform temporarily unavailable to login
Incident Report for Labelbox
Postmortem

Summary

An issue in our automated deployment tooling caused Labelbox services to become unavailable. The malfunction did not affect any data storage, database, network, security, or other infrastructure. A change to the automated deployment tooling was reverted and services were automatically restored. 

Details

A configuration change was made Friday, October 20th at approximately 15:45 PT (22:45 UTC) that was believed to be benign. However, when this change propagated through the configuration system it had unintended consequences. This resulted in Labelbox services becoming unavailable for approximately one hour.

The malfunction did not affect any data storage, database, network, security, or other infrastructure, and no data was lost or affected by the outage.

The change to the automated deployment tooling was reverted and services were automatically restored. The restoration of the services took some time to stabilize. The incident was deemed fully resolved at 16:56 PT (23:56 UTC)

Labelbox has already completed several changes to prevent this type of issue from being able to occur again.

Posted Oct 24, 2023 - 20:07 UTC

Resolved
This incident has been resolved. We are continuing to monitor for any further issues.
Posted Oct 21, 2023 - 00:54 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 21, 2023 - 00:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2023 - 00:24 UTC
Update
A fix has been made and services are returning to a normal state. This will take some time before the platform is fully available.
Posted Oct 20, 2023 - 23:25 UTC
Identified
We've identified an issue with our CD system and are working on a fix.
Posted Oct 20, 2023 - 23:05 UTC
Investigating
We are currently investigating this issue.
Posted Oct 20, 2023 - 23:01 UTC
This incident affected: Catalog, Model, Annotate, Platform (common services), and Google infrastructure.